Start a conversation

Enable ZendGuard Loader - Linux

The Scriptcase need ZendGuard Loader enabled in php.ini to decrypt their internal files, to the execution of the system is possible.

If you do not have the ZendGuard Lodar enabled, a message will appear like this in your browser:



We need to perform some steps and changes in some of the php files to enable this module.

First we download the ZendGuardLoader: click here.

Remember to download the Loader ZendGuard specific to your operating system and php.

  - To check the extensions directory access through your browser:
   -ip:port/scriptcase/info.php
    - Search for: "extension_dir"


After downloading the ZendGuardLoader.so place the file in the php extensions directory:


To check which directory is the php.ini file access through the browser:
  - ip:port/scriptcase/info.php
    - Search for "Configuration File (php.ini) Path"


Open the php.ini file and add in the end:

[Zend]
zend_extension = <full_path/ZendGuardLoader.so>
zend_loader.enable = 1
zend_loader.disable_licensing = 0
zend_loader.license_path =



restart apache:

sudo /etc/init.d/apache2 stop
sudo /etc/init.d/apache2 start

Access your ip:port/scriptcase/diagnosis and see the line of ZendGuardLoader enabled:

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Ronyan Alves

  2. Posted
  3. Updated

Comments