Start a conversation

PDF generation displays message: "Not Found"

Then follow the step by step to perform the correction of the error "Not Found" when running the PDF generation.

First step:
Navigate to the folder 'tmp' in its publication folder. Open the file ".log", which was generated with the name of your PDF. and save your content.

Second step :

LINUX:

After this, open your terminal server, type "cd /publication_folder/_lib/prod/third/wkhtmltopdf/linux-i386 or linux-amd64", choose according to your version of Linux .

WINDOWS:

After this, open your terminal server, type "cd /publication_folder/_lib/prod/third/wkhtmltopdf/win".

MACOSX:

After this, open your terminal server, type "cd /publication_folder/_lib/prod/third/wkhtmltopdf/osx".


Third step:

Now, that you are in "/publication_folder/_lib/prod/third/wkhtmltopdf/OS_folder", run the command that was saved on the one step.

Fourth step:

Will be displayed an error, it which say that is missing a library on your operational system. Perform the installation of the library applied for and try to perform the generation of the PDF again.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Ronyan Alves

  2. Posted
  3. Updated

Comments

  1. Gustavo Veras Sampaio

    Olá Araken, tudo bom? Os pré requisitos são : PHP 5.4 ou 5.6 (Dependendo da versão do Scriptcase) com os módulos mbstring, zip e gd2 habilitados. Funções do PHP habilitadas : - dir - readdir - opendir - eval - exec - set_time_limit - ini_alter - ini_set - ini_restore - php_uname - popen - proc_close - proc_get_status - proc_open - shell_exec - system Estas funções devem está habilitadas tanto para o ambiente de desenvolvimento, quanto para o ambiente de produção. Caso algumas dessas funções estejam desabilitadas, o funcionamento do Scriptcase e das aplicações publicadas neste ambiente estarão comprometidos. Atenciosamente, Equipe Scriptcase
  2. Araken Lotufo Ferraz de Oliveira

    meu scriptcase roda em um servidor compartilhado na locaweb quais são as biblliotecas necessárias para que ela funcione. tem com o lista-las no link info.php que passei não tem como vc verificar se estão instaladas?