Iniciar uma conversa

Habilitar Zend Guard Loader - Linux

O scriptcase necessita do ZendGuard Loader habilitado no php.ini para que o php possa interpretar seus arquivos internos, sendo possível a execução dos sistema.

Caso não possua o ZendGuard Lodar habilitado, aparecerá uma mensagem como esta em seu browser:



Necessitamos executar alguns passos e alterações em alguns arquivos do php para habilitar este módulo.

Primeiramente vamos fazer o download do ZendGuardLoader: clique aqui.

Lembre-se de fazer o download do ZendGuard Loader especifico para o seu php e sistema operacional.

 - Para verificar o diretório de extensões acesse através de seu browser:
  -ip:porta/scriptcase/info.php
   - Procure por: "extension_dir"


Após o download coloque o arquivo ZendGuardLoader.so no diretório de extensões do php:


Para verificar em qual diretório está o arquivo php.ini acesse por meio do browser:
 - ip:porta/scriptcase/info.php
   - Procure por: "Configuration File (php.ini) Path"


Abra o arquivo php.ini e ao final adicione:

[zend]
zend_extension=<caminho_completo/ZendGuardLoader.so>
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.license_path=



reinicie o apache:
sudo /etc/init.d/apache2 stop
sudo /etc/init.d/apache2 start

 

Acesse seuip:porta/scriptcase/diagnosis e veja a linha do ZendGuardLoader habilitado:

Escolher arquivos ou arraste e solte arquivos
Esse artigo foi útil?
Sim
Não
  1. Ronyan Alves

  2. Publicado
  3. Atualizado

Comentários