Iniciar uma conversa

Geração de PDF exibe mensagem: "Not Found"

Em seguida, siga o passo a passo para realizar a correção do erro "Not Found" ao executar a geração de PDF.

Primeira etapa:


Navegue até a pasta 'tmp' em sua pasta publicação. Abra o arquivo "log", que foi gerado com o nome do seu PDF. e salve o seu conteúdo.

Segundo passo:

LINUX:

Após isso, abra o  terminal de seu servidor, digite "cd /pasta_publicacao/_lib/prod/third/wkhtmltopdf/linux-i386 ou linux-amd64", escolha de acordo com a sua versão do Linux.

WINDOWS:

Após isso, abra o  terminal de seu servidor, digite "cd /pasta_publicacao/_lib/prod/third/wkhtmltopdf/win".

MACOSX:

Após isso, abra o  terminal de seu servidor, digite "cd /pasta_publicacao/_lib/prod/third/wkhtmltopdf/OSX".


Terceiro passo:

Agora, se você está em "/pasta_publicacao/_lib/prod/third/wkhtmltopdf/pasta_SO", execute o comando que foi salvo no passo um.

Quarta etapa:

Será exibido um erro, que diz que é a falta de uma biblioteca em seu sistema operacional. Realize a instalação da biblioteca pedida e tente executar a geração do PDF novamente.

Escolher arquivos ou arraste e solte arquivos
Esse artigo foi útil?
Sim
Não
  1. Ronyan Alves

  2. Publicado
  3. Atualizado

Comentários

  1. Gustavo Veras Sampaio

    Olá Araken, tudo bom? Os pré requisitos são : PHP 5.4 ou 5.6 (Dependendo da versão do Scriptcase) com os módulos mbstring, zip e gd2 habilitados. Funções do PHP habilitadas : - dir - readdir - opendir - eval - exec - set_time_limit - ini_alter - ini_set - ini_restore - php_uname - popen - proc_close - proc_get_status - proc_open - shell_exec - system Estas funções devem está habilitadas tanto para o ambiente de desenvolvimento, quanto para o ambiente de produção. Caso algumas dessas funções estejam desabilitadas, o funcionamento do Scriptcase e das aplicações publicadas neste ambiente estarão comprometidos. Atenciosamente, Equipe Scriptcase
  2. Araken Lotufo Ferraz de Oliveira

    meu scriptcase roda em um servidor compartilhado na locaweb quais são as biblliotecas necessárias para que ela funcione. tem com o lista-las no link info.php que passei não tem como vc verificar se estão instaladas?